CP/M-Forum

Registrieren || Einloggen || Hilfe/FAQ || Suche || Memberlist || Home || Statistik || Kalender || Staff Willkommen Gast!
[ Unofficial CP/M Website ] [ Z80 Family Support Page ] [ Forum-Regeln ] [ Impressum/Kontakt ] [ Datenschutzerklärung ]

CP/M-Forum » Computer » CKZ 80 -- Bitte um Tips » Threadansicht

Autor Thread - Seiten: -1- [ 2 ] [ 3 ]
000
29.11.2007, 19:51 Uhr
mister-freeze



Hallo zusammen,

hat jemand evtl Unterlagen zum Z80 ECB Rechner CKZ 80 ?

Habe da ein ECB- System geschenkt bekommen, krieg das aber leider nicht zum laufen...
CPU - Karte : CKZ 80
RAM: CKZ MEGA
desweiteren ist noch eine Solid-State Floppy sowie ein Floppycontroller verbaut.
Habe serielle Anschlküsse an der CPU-Karte ausmachen können, und habe versucht ein Terminal anzuschliessen. (Der Vorbesitzer erwähnte was von einer Bedienung per Terminal konnte sich aber nicht genauer erinnern)
Desweiteren ist in einem Frontblech (Neben den seriellen Anschlüssen der CPU-Karte) eine BNC-Buchse mit losem Kabel angebracht. (könnte das ggf auf eine fehlende Karte hinweisen ?)

Vielleicht hat ja einer einen Tip.....
Ich bitte aber jetzt schon um Nachsicht, bin Anfänger !

Schöne Grüsse,
Christian
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
001
29.11.2007, 20:23 Uhr
Alfred

Avatar von Alfred

Hallo Christian,

die CPU-Karte kenne ich leider noch nicht, ohne Unterlagen wird es etwas schwierig.
Speziell die Stecker- und Jumperbelegung wäre für die ersten Schritte wichtig.
Welche Bausteine sind auf der CPU-Karte drauf (Z80 CPU/SIO/PIO/CTC/RAM/EPROM mit Monitor
etc.), welcher Controller ist auf der Floppykarte?
PS: Das Koaxkabel zur BNC-Buchse war vermutlich der Monitoranschluß von einer Terminalkarte.

Grüsse
Alfred
--
Das Leben ist verdammt kurz (meine Meinung)!

Dieser Post wurde am 29.11.2007 um 20:24 Uhr von Alfred editiert.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
002
29.11.2007, 21:26 Uhr
mister-freeze



Habe jetzt mal Fotos von
CPU / RAM / FDC Karte gemacht.

http://www.mister-freeze.net/bilder/CZK80.jpg
http://www.mister-freeze.net/bilder/CZKMEGA.jpg
http://www.mister-freeze.net/bilder/CZK%20FDC.jpg
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
003
30.11.2007, 17:30 Uhr
Alfred

Avatar von Alfred

Hallo Christian,

das wird nicht einfach, hat evtl. der Vorbesitzer noch Informationen zu den Boards.
Auffällig ist, daß auf der CPU-Karte zwei 18-polige Fassungen leer sind.
Das kann ein Problem sein, oder auch nicht!?

Grüsse
Alfred
--
Das Leben ist verdammt kurz (meine Meinung)!

Dieser Post wurde am 30.11.2007 um 17:31 Uhr von Alfred editiert.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
004
01.12.2007, 17:03 Uhr
mister-freeze



Habe leider keine Unterlagen zu diesem Rechner dazubekommen. Allerdings sind einige Disketten dabei.... aber dafür muss der Rechner ja erstmal laufen.
In einer beigelegten Ersatzteilkiste befindet sich dasselbe CPU -Board mit den gleichen Einstellungen noch einmal. Da fehlen genau die selben Bausteine und darüber hinaus das EPROM. Ich glaube mal das mit den zwei fehlenden Bausteinen ist so gewollt.

Kennt jemand diesen Rechner bzw. hat jemand Unterlagen dafür ?

Schöne Grüsse und Danke für die Unterstützung .

Christian
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
005
01.12.2007, 17:43 Uhr
HD64180CPM



Hallo Christian,

kannst Du das EPROM auslesen und die Daten von den EPROM zum
downloaden stellen.

Hast Du das Programm ANADISK damit kannst Du die Disketten vielleicht
lesen und ein Image machen, glaube es heißt bei ANADISK der Menü-Punkt
DUMP.

Dieses Image kannst Du vielleicht auch zum downloaden stellen.

Es kann leider ohne Unterlagen lange dauern bis Dein CKZ 80 wieder richtig
läuft,aber wenn Du die Platine untersuchst ganz Du Daten bekommen wie die
RS232-Schnittstelle angeschlossen ist.

Habe ich auch bei meinen ECB-Rechner von der Firma SYSTEC hin bekommen.

Gruss
Rolf
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
006
01.12.2007, 18:41 Uhr
mister-freeze



Hallo,

Das mit dem EPROM ist gar nicht so einfach, bin da auf Hilfe angewiesen....
Das mit den Disketten ebenfalls. Ich weiss nicht zu 100% welche Disks zu welchem System gehören. Aussserdem habe ich keinen PC mit 8" Laufwerk, eben nur meine ECB-Systeme. muss ich noch Forschung betreiben... sind nämlch CP/M , MP/M und CP/M68k Disks bunt gemischt.
Werde mich mal um die 2 Punkte bemühen..

Der Anschluss der RS232 Schnittstellen ist mir allerdings klar. Eine angeschlossene SUB-D Buchse sowie ein Diodensteckerbuchse die über ein gemeinsames Flachbandkabel mit auf der Platine an die 4 IC´s (Foto oben rechts) geführt sind. An den Diodenstecker sind, wenn ich das vom SUB-D Stecker gedanklich übertrage GND, RXD und TXD geführt.

Da ich in gleichem Posten ein Terminal erhalten habe das über denselben Stecker mit derselben Belegung verfügt(GND, RXD, TXD), habe ich das entsprechend zusammengeschlossen. Erfolg: Kein Datenverkehr von Seiten der CPU Platine (auch kein Echo). Habe auch mal mit dem Logiktester am Diodenstecker gelauscht.--> keine Signalveränderungen.

Gruss,
Christian

Dieser Post wurde am 01.12.2007 um 18:42 Uhr von mister-freeze editiert.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
007
01.12.2007, 18:54 Uhr
Alfred

Avatar von Alfred

Hallo Christian,
liefert das Netzteil alle Spannungen (5V +/-12V)?
Funktioniert die PowerOn Resetlogic und der 16 Mhz Taktoszillator?
Teilt vermutlich durch 4 = 4Mhz CPU Takt, evtl. ist auch der Quarz defekt.
An der CPU Pin26 (Reset) bzw. Pin6 (Clock) kontrollieren, ein Oszi
wäre da zur Kontrolle nicht schlecht.
Viel Erfolg
Alfred
--
Das Leben ist verdammt kurz (meine Meinung)!
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
008
05.12.2007, 20:20 Uhr
mister-freeze



Hi Alfred,

vielen Dank erstmal für die Tips,
werde mir ein Oszi ausleihen und da mal nachmessen.
melde mich wieder wenn ich die Ergebnisse habe.

Gruß,
Christian
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
009
20.01.2008, 20:31 Uhr
mister-freeze



Power on Reset geht,
Takt ist auch da.
Hat noch jemand Ideen ?

Gruss,
Christian

Dieser Post wurde am 20.01.2008 um 20:32 Uhr von mister-freeze editiert.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
010
22.01.2008, 19:51 Uhr
Alfred

Avatar von Alfred

Hallo Christian,

wird das EPROM angesprochen und ist dort auch ein Programm drin?
Du könntest mit dem Oszi mal die Signale auf dem Bus anschauen.
Interessant wären IORQ, MREQ und die Daten- Adressleitungen.
Dort sollte nach einem Reset Aktivitäten sichtbar sein.
Evtl. ein Eprom mit einer Schleife und paar Befehlen brennen, z.B.:

IN A,(0)
OUT (0),A
LD A,(0)
LD (0),A
JP 0

DB 00 D3 00 3A 00 00 32 00 00 C3 00 00

Grüsse
Alfred
--
Das Leben ist verdammt kurz (meine Meinung)!
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
011
23.01.2008, 22:37 Uhr
mister-freeze



Vielen Dank Alfred.

Habe auf 27a: /IORQ gleichblebendes Muster mit Pulsen
auf 28a: /RFSH gleichmässige Pulse
auf 30c: /MREQ gleichmässige Pulse

(soweit erkennbar, ich krieg die Triggerung vom Oszi nicht richtig hin)

auf jeden Fall verschwindet jede Signaltätigkeit beim Anlegen von Reset.
Bei entfernter Speicherkarte verschwindet die Signaltätigkeit von
IORQ (bleibt auf +5V)
Die von RFSH und von MREQ steht leicht verändert auch bei entfernter Speicherkarte an.
Auch auf D0 und A0 gleichbleibende Frequenzbilder am Oszi.
Auch hier bei Reset, die Leitungen auf 0 bzw 1

Wären diese Zustände soweit normal ?

Wegen auslesen des Eproms wirds mangels Wissen und Ausrüstung schwierig.
Muss mal sehn, dass ich da regionale Unterstützung bekomme..

Schöne Grüsse,

Christian
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
012
24.01.2008, 17:56 Uhr
Alfred

Avatar von Alfred

Hallo Christian,

wenn die Signale da sind, funktioniert deine Hardware soweit, auch dürfte die
Software im Eprom ok sein.
Es könnte evtl. die RS232 Schnittstelle blockiert sein.
Ich würde jeweils RTS + CTS , DSR + DTR + DCD und RXD + TXD verbinden
und mit dem OSZI schauen ob auf RXD/TXD etwas rauskommt.
Ein PC mit einer Terminalsoftware wie z.B. PROCOM oder TELIX wäre zum
Test der unterschiedlichen Baudraten etc. auch nicht schlecht.
Dann natürlich TXT/RXD wieder auftrennen, zum testen reicht TXT/RXD und GND.

Grüsse
Alfred
--
Das Leben ist verdammt kurz (meine Meinung)!
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
013
26.01.2008, 23:14 Uhr
mister-freeze



Hi,

leider ohne Ergebnis.
Schnittstellen bleiben stumm.

Gruss,
Christian
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
014
26.01.2008, 23:20 Uhr
Alfred

Avatar von Alfred

Hallo Christian,

prüfe mal, ob an dem CTC bzw. DART die Baudrate anliegt,
evtl. ist da der Wurm drin, bzw. fehlt ein Jumper!?

Grüsse
Alfred
--
Das Leben ist verdammt kurz (meine Meinung)!
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
015
27.01.2008, 00:17 Uhr
mister-freeze



Meinst du die Anschlüsse RXCA TXCA RXCB und TXCB ?
Da habe ich einen Takt anliegen.

Am Chip Enable kommt auch ein Signal an.


Ich werde das Gefühl nicht los, dass dem Kasten doch eine Grafikkarte oder Terminalkarte fehlt...
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
016
27.01.2008, 00:46 Uhr
DG8FAC



Hi Christian,
Rolf hat da recht, Du solltes mal irgend wie das EPROM lesen,
dann weiss man ob er ein Terminal über den ECB sucht, oder
über die RS232... in dem Fall ist was faul an der Hardware :-(
Falls Du keine Möglichkeit hast, schick das EPROM zu mir
ich les das aus und schick es Dir wieder...

Gruß
Stefan
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
017
28.01.2008, 21:01 Uhr
mister-freeze



@DG8FAC
Vielen Dank für das Angebot.

Habe mich mittlerweile dazu entschlossen mir einen Eprommer anzuschaffen.
Ist schon bestellt, melde mich wieder sobald ich das Eprom ausgelesen habe.

Gruss, Christian
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
018
02.02.2008, 11:13 Uhr
mister-freeze



Hallo,

hier nun endlich das eprom:

http://www.mister-freeze.net/CZK80.BIN

lg
Christian
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
019
02.02.2008, 14:11 Uhr
Alfred

Avatar von Alfred

Hallo Christian,

hab mal auf die Schnelle das File angeschaut.
Es enthält ein CP/M 2.2 und ein User Bios.
Als Autor steht dort "gerhard bundle" und
CP/M 2.2 (c) by DIGITAL RESEARCH
BIOS 2.27 (c) by Gunter Michalk
Der erste Sprung geht nach FF80 (C3 80 FF) und dort liegt
31 33 F0
21 80 FF
11 88 FF
01 80 00
ED B0
21 00 E0
11 00 DA
01 03 1F
ED B0
3E 02
D3 40
C9
usw.

Grüsse
Alfred
--
Das Leben ist verdammt kurz (meine Meinung)!
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
020
03.02.2008, 08:16 Uhr
mister-freeze



Hi,
leider kann ich das nicht interpretieren.
Kannst du mir sagen was das bedeutet in Sachen primäres EIn-Ausgabegerät ?
Danke,
lg
Christian
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
021
03.02.2008, 10:37 Uhr
HD64180CPM



Hallo Christian,

laut meinen Z80 Simulator fehlt der Adressen-Bereich ab 0FF80H.

Ich haben meinen Z80 Simulator den Eprom-Inhalt laden lassen,
der spring nach 0FF80H und der Bereich fehlt leider.

Den Eprom-Inhalt muss ich noch auswerten.

Gruss
Rolf
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
022
03.02.2008, 12:57 Uhr
DG8FAC



Hi Christian,

Schau doch mal was auf I/O Adr. 40H angesprochen wird, CTC, PIO oder DART?
Ich geh mal davon aus, da am DART ja Takt anliegt, das dieser von
PIN 7, 8 oder 9 der CTC kommt, also wird die initialisiert.
Du müsstes mal "rausklingeln" wo das CE PIN16 der CTC auf den 74LS138 geht,
und an welchen Adr. Leitungen der 138 hängt, da könnt man schon mal sehen
welche I/O Adr. zum Board gehören.. das macht das debuggen einfacher :-)

Gruss
Stefan
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
023
03.02.2008, 16:52 Uhr
mister-freeze




Zitat:
DG8FAC postete
Hi Christian,

Schau doch mal was auf I/O Adr. 40H angesprochen wird, CTC, PIO oder DART?
Ich geh mal davon aus, da am DART ja Takt anliegt, das dieser von
PIN 7, 8 oder 9 der CTC kommt, also wird die initialisiert.
Du müsstes mal "rausklingeln" wo das CE PIN16 der CTC auf den 74LS138 geht,
und an welchen Adr. Leitungen der 138 hängt, da könnt man schon mal sehen
welche I/O Adr. zum Board gehören.. das macht das debuggen einfacher :-)

Gruss
Stefan

Habe mal durchgeklingelt.


CE Pin 16 der CTC geht auf Pin 10 des LS138 (und auf Pin 5 des LS10)

PIN 1 des LS138 geht auf PIN 8 Des Eproms, PIN3 des unteren LS244, Pin 7 des linken und rechten freien Sockels, und auf Stift 6A des ECB

PIN 2 des LS238 geht auf PIN 7 des Eproms, PIN12 des mittleren LS244, jew. Pin 4 der freien Sockel, Stift 6C des ECB

PIN 3 des LS238 geht auf PIN 6 des Eproms, Pin14 des mittleren LS244, Stift jew. Pin 3 der freien Sockel , Stift 7a des ECB

PIN 4 des LS238 geht auf Pin 5 des Eproms, auf Pin 16 des mittleren LS244, jew. Pin 2 der freien Sockel, Stift 8a des ECB

Pin 5 des LS238 geht auf PIN 3 des Eproms, auf Pin 9 des mittleren LS244, jew. PIN17 der freien Sockel, Stift 9C des ECB

Pin 6 des LS238 geht auf Pin 4 des Eproms, auf Pin 18 des mittleren LS244,
jew. auf Pin 1 der freien Sockel


Ich hoffe das war was du gemeint hast

Danke lg Chr.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
024
03.02.2008, 22:37 Uhr
DG8FAC



Hi Christian,
also PIN1 von den 18PIN Sockel, da könnten RAMs 2114 rein passen, das ist A6?
PIN11 bis 14 am 18Pin sind die Datenleitungen, die sollten auch am EPROM sein.

Und ich geh mal davon aus das Du mit LS238 den LS138 meinst :-)
Ich schau mir das mal aufm Papier an und schreib nochmal bescheid..

Gruss
Stefan
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
Seiten: -1- [ 2 ] [ 3 ]     [ Computer ]  



gaby.de

powered by ThWboard 3 Beta 2.84-php5
© by Paul Baecher & Felix Gonschorek